What’s Vulnerable › Vulnerabilities
CVE-2022-0575: Cross-site Scripting (XSS) - Stored in librenms/librenms
- Severity: medium (CVSS 5.4 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.8% probability of exploitation in the next 30 days
- Public exploit or detection template: yes
- Published: 2022-02-14 · updated 2026-06-17
- Weakness: CWE-79
Description
Cross-site Scripting (XSS) - Stored in Packagist librenms/librenms prior to 22.2.0.
Affected products
- librenms: before 22.2.0 — fixed in 22.2.0
How to fix
Upgrade to a fixed version: librenms 22.2.0. Check the vendor advisory for mitigations.
References
- https://github.com/librenms/librenms/commit/4f86915866703e2fcd1e34b3fc1181ec2ad78e54
- https://huntr.dev/bounties/13951f51-deed-4a3d-8275-52306cc5a87d
- https://notes.netbytesec.com/2022/02/multiple-vulnerabilities-in-librenms.html
- https://github.com/librenms/librenms/commit/4f86915866703e2fcd1e34b3fc1181ec2ad78e54
- https://huntr.dev/bounties/13951f51-deed-4a3d-8275-52306cc5a87d
- https://notes.netbytesec.com/2022/02/multiple-vulnerabilities-in-librenms.html
Get alerted when CVE-2022-0575 or the next vulnerability affects your stack