What’s Vulnerable › Vulnerabilities
CVE-2022-0576: Cross-site Scripting (XSS) - Generic in librenms/librenms
- Severity: medium (CVSS 6.1 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 1.0% probability of exploitation in the next 30 days
- Public exploit or detection template: yes
- Published: 2022-02-14 · updated 2026-06-17
- Weakness: CWE-79
Description
Cross-site Scripting (XSS) - Generic in Packagist librenms/librenms prior to 22.1.0.
Affected products
- librenms: before 22.2.0 — fixed in 22.2.0
How to fix
Upgrade to a fixed version: librenms 22.2.0. Check the vendor advisory for mitigations.
References
- https://github.com/librenms/librenms/commit/135717a9a05c5bf8921f1389cbb469dcbf300bfd
- https://huntr.dev/bounties/114ba055-a2f0-4db9-aafb-95df944ba177
- https://notes.netbytesec.com/2022/02/multiple-vulnerabilities-in-librenms.html
- https://github.com/librenms/librenms/commit/135717a9a05c5bf8921f1389cbb469dcbf300bfd
- https://huntr.dev/bounties/114ba055-a2f0-4db9-aafb-95df944ba177
- https://notes.netbytesec.com/2022/02/multiple-vulnerabilities-in-librenms.html
Get alerted when CVE-2022-0576 or the next vulnerability affects your stack