What’s Vulnerable › Vulnerabilities
CVE-2022-0577: Exposure of Sensitive Information to an Unauthorized Actor in scrapy/scrapy
- Severity: medium (CVSS 6.5 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 1.2% probability of exploitation in the next 30 days
- Public exploit or detection template: yes
- Published: 2022-03-02 · updated 2026-06-17
- Weakness: CWE-200
Description
Exposure of Sensitive Information to an Unauthorized Actor in GitHub repository scrapy/scrapy prior to 2.6.1.
Affected products
- Debian Linux: 9.0
- scrapy/scrapy: before 2.6.1 — fixed in 2.6.1
How to fix
Upgrade to a fixed version: scrapy/scrapy 2.6.1. Check the vendor advisory for mitigations.
References
- https://github.com/scrapy/scrapy/commit/8ce01b3b76d4634f55067d6cfdf632ec70ba304a
- https://huntr.dev/bounties/3da527b1-2348-4f69-9e88-2e11a96ac585
- https://lists.debian.org/debian-lts-announce/2022/03/msg00021.html
- https://github.com/scrapy/scrapy/commit/8ce01b3b76d4634f55067d6cfdf632ec70ba304a
- https://huntr.dev/bounties/3da527b1-2348-4f69-9e88-2e11a96ac585
- https://lists.debian.org/debian-lts-announce/2022/03/msg00021.html
Get alerted when CVE-2022-0577 or the next vulnerability affects your stack