What’s Vulnerable › Vulnerabilities
CVE-2022-0580: Incorrect Authorization in librenms/librenms
- Severity: high (CVSS 8.8 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 1.2% probability of exploitation in the next 30 days
- Public exploit or detection template: yes
- Published: 2022-02-14 · updated 2026-06-17
- Weakness: CWE-863
Description
Incorrect Authorization in Packagist librenms/librenms prior to 22.2.0.
Affected products
- librenms: before 22.2.0 — fixed in 22.2.0
How to fix
Upgrade to a fixed version: librenms 22.2.0. Check the vendor advisory for mitigations.
References
- https://github.com/librenms/librenms/commit/95970af78e4c899744a715766d744deef8c505f7
- https://huntr.dev/bounties/2494106c-7703-4558-bb1f-1eae59d264e3
- https://notes.netbytesec.com/2022/02/multiple-vulnerabilities-in-librenms.html
- https://github.com/librenms/librenms/commit/95970af78e4c899744a715766d744deef8c505f7
- https://huntr.dev/bounties/2494106c-7703-4558-bb1f-1eae59d264e3
- https://notes.netbytesec.com/2022/02/multiple-vulnerabilities-in-librenms.html
Get alerted when CVE-2022-0580 or the next vulnerability affects your stack