What’s Vulnerable › Vulnerabilities
CVE-2022-0589: Cross-site Scripting (XSS) - Stored in librenms/librenms
- Severity: medium (CVSS 5.4 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.8% probability of exploitation in the next 30 days
- Public exploit or detection template: yes
- Published: 2022-02-15 · updated 2026-06-17
- Weakness: CWE-79
Description
Cross-site Scripting (XSS) - Stored in Packagist librenms/librenms prior to 22.1.0.
Affected products
- librenms: before 22.1.0 — fixed in 22.1.0
How to fix
Upgrade to a fixed version: librenms 22.1.0. Check the vendor advisory for mitigations.
References
- https://github.com/librenms/librenms/commit/4c9d4eefd8064a0285f9718ef38f5617d7f9d6fa
- https://huntr.dev/bounties/d943d95c-076f-441a-ab21-cbf6b15f6768
- https://notes.netbytesec.com/2022/02/multiple-vulnerabilities-in-librenms.html
- https://github.com/librenms/librenms/commit/4c9d4eefd8064a0285f9718ef38f5617d7f9d6fa
- https://huntr.dev/bounties/d943d95c-076f-441a-ab21-cbf6b15f6768
- https://notes.netbytesec.com/2022/02/multiple-vulnerabilities-in-librenms.html
Get alerted when CVE-2022-0589 or the next vulnerability affects your stack