What’s Vulnerable › Vulnerabilities
CVE-2022-0590: BulletProof Security < 5.8 - Admin+ Stored Cross-Site Scripting (XSS)
- Severity: medium (CVSS 4.8 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.6% probability of exploitation in the next 30 days
- Public exploit or detection template: yes
- Published: 2022-03-21 · updated 2026-06-17
- Weakness: CWE-79
Description
The BulletProof Security WordPress plugin before 5.8 does not sanitise and escape some of its settings, which could allow high privilege users to perform Cross-Site Scripting attacks even when the unfiltered_html capability is disallowed.
Affected products
- BulletProof Security: before 5.8 — fixed in 5.8
How to fix
Upgrade to a fixed version: BulletProof Security 5.8. Check the vendor advisory for mitigations.
References
- https://wpscan.com/vulnerability/08b66b69-3c69-4a1e-9c0a-5697e31bc04e
- https://wpscan.com/vulnerability/08b66b69-3c69-4a1e-9c0a-5697e31bc04e
Get alerted when CVE-2022-0590 or the next vulnerability affects your stack