What’s Vulnerable › Vulnerabilities
CVE-2022-0596: Improper Validation of Specified Quantity in Input in microweber/microweber
- Severity: medium (CVSS 4.3 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.6% probability of exploitation in the next 30 days
- Public exploit or detection template: yes
- Published: 2022-02-15 · updated 2026-06-17
- Weakness: CWE-1284
Description
Improper Validation of Specified Quantity in Input in Packagist microweber/microweber prior to 1.2.11.
Affected products
- microweber/microweber: before 1.2.11 — fixed in 1.2.11
How to fix
Upgrade to a fixed version: microweber/microweber 1.2.11. Check the vendor advisory for mitigations.
References
- https://github.com/microweber/microweber/commit/91a9d899741557c75050614ff7adb8c0e3feb005
- https://huntr.dev/bounties/f68b994e-2b8b-49f5-af2a-8cd99e8048a5
- https://github.com/microweber/microweber/commit/91a9d899741557c75050614ff7adb8c0e3feb005
- https://huntr.dev/bounties/f68b994e-2b8b-49f5-af2a-8cd99e8048a5
Get alerted when CVE-2022-0596 or the next vulnerability affects your stack