What’s Vulnerable › Vulnerabilities
CVE-2022-0602: Cross-site Scripting (XSS) - DOM in tastyigniter/tastyigniter
- Severity: medium (CVSS 5.4 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.7% probability of exploitation in the next 30 days
- Public exploit or detection template: yes
- Published: 2022-04-05 · updated 2026-06-17
- Weakness: CWE-79
Description
Cross-site Scripting (XSS) - DOM in GitHub repository tastyigniter/tastyigniter prior to 3.3.0.
Affected products
- tastyigniter/tastyigniter: before 3.3.0 — fixed in 3.3.0
How to fix
Upgrade to a fixed version: tastyigniter/tastyigniter 3.3.0. Check the vendor advisory for mitigations.
References
- https://github.com/tastyigniter/tastyigniter/commit/992d4ce6444805c3132e3635a01b6fd222063554
- https://huntr.dev/bounties/615f1788-d474-4580-b0ef-5edd50274010
- https://github.com/tastyigniter/tastyigniter/commit/992d4ce6444805c3132e3635a01b6fd222063554
- https://huntr.dev/bounties/615f1788-d474-4580-b0ef-5edd50274010
Get alerted when CVE-2022-0602 or the next vulnerability affects your stack