What’s Vulnerable › Vulnerabilities
CVE-2022-0627: Amelia < 1.0.46 - Reflected Cross-Site Scripting
- Severity: medium (CVSS 6.1 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.8% probability of exploitation in the next 30 days
- Public exploit or detection template: yes
- Published: 2022-03-21 · updated 2026-06-17
- Weakness: CWE-79
Description
The Amelia WordPress plugin before 1.0.47 does not sanitize and escape the code parameter before outputting it back in an admin page, leading to a Reflected Cross-Site Scripting.
Affected products
- TMS Amelia: before 1.0.47 — fixed in 1.0.47
How to fix
Upgrade to a fixed version: TMS Amelia 1.0.47. Check the vendor advisory for mitigations.
References
- https://wpscan.com/vulnerability/fd8c720a-a94a-438f-b686-3a734e3c24e4
- https://wpscan.com/vulnerability/fd8c720a-a94a-438f-b686-3a734e3c24e4
Get alerted when CVE-2022-0627 or the next vulnerability affects your stack