What’s Vulnerable › Vulnerabilities
CVE-2022-0628: AP Mega Menu < 3.0.8 - Reflected Cross-Site Scripting
- Severity: medium (CVSS 6.1 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.9% probability of exploitation in the next 30 days
- Public exploit or detection template: yes
- Published: 2022-03-21 · updated 2026-06-17
- Weakness: CWE-79
Description
The Mega Menu WordPress plugin before 3.0.8 does not sanitize and escape the _wpnonce parameter before outputting it back in an admin page, leading to a Reflected Cross-Site Scripting.
Affected products
- Mega Menu Plugin for WordPress – AP Mega Menu: before 3.0.8 — fixed in 3.0.8
How to fix
Upgrade to a fixed version: Mega Menu Plugin for WordPress – AP Mega Menu 3.0.8. Check the vendor advisory for mitigations.
References
- https://plugins.trac.wordpress.org/changeset/2684307
- https://wpscan.com/vulnerability/af9787ee-c496-4f02-a22c-c8f8a97ad902
- https://plugins.trac.wordpress.org/changeset/2684307
- https://wpscan.com/vulnerability/af9787ee-c496-4f02-a22c-c8f8a97ad902
Get alerted when CVE-2022-0628 or the next vulnerability affects your stack