What’s Vulnerable › Vulnerabilities
CVE-2022-0640: AP Pricing Tables Lite < 1.1.5 - Reflected Cross-Site Scripting
- Severity: medium (CVSS 6.1 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.9% probability of exploitation in the next 30 days
- Public exploit or detection template: yes
- Published: 2022-03-21 · updated 2026-06-17
- Weakness: CWE-79
Description
The Pricing Table Builder WordPress plugin before 1.1.5 does not sanitize and escape the postid parameter before outputting it back in an admin page, leading to a Reflected Cross-Site Scripting.
Affected products
- Pricing Table Builder – AP Pricing Tables Lite: before 1.1.5 — fixed in 1.1.5
How to fix
Upgrade to a fixed version: Pricing Table Builder – AP Pricing Tables Lite 1.1.5. Check the vendor advisory for mitigations.
References
- https://plugins.trac.wordpress.org/changeset/2684253
- https://wpscan.com/vulnerability/f8405e06-9cf3-4acb-aebb-e80fb402daa9
- https://plugins.trac.wordpress.org/changeset/2684253
- https://wpscan.com/vulnerability/f8405e06-9cf3-4acb-aebb-e80fb402daa9
Get alerted when CVE-2022-0640 or the next vulnerability affects your stack