What’s Vulnerable › Vulnerabilities
CVE-2022-0658: CommonsBooking < 2.6.8 - Unauthenticated SQL Injection
- Severity: critical (CVSS 9.8 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 7.5% probability of exploitation in the next 30 days
- Public exploit or detection template: yes
- Published: 2022-03-14 · updated 2026-06-17
- Weakness: CWE-89
Description
The CommonsBooking WordPress plugin before 2.6.8 does not sanitise and escape the location parameter of the calendar_data AJAX action (available to unauthenticated users) before it is used in dynamically constructed SQL queries, leading to an unauthenticated SQL injection
Affected products
- CommonsBooking: before 2.6.8 — fixed in 2.6.8
How to fix
Upgrade to a fixed version: CommonsBooking 2.6.8. Check the vendor advisory for mitigations.
References
- https://wpscan.com/vulnerability/d7f0805a-61ce-454a-96fb-5ecacd767578
- https://wpscan.com/vulnerability/d7f0805a-61ce-454a-96fb-5ecacd767578
Get alerted when CVE-2022-0658 or the next vulnerability affects your stack