What’s Vulnerable › Vulnerabilities
CVE-2022-0663: Print, PDF, Email by PrintFriendly < 5.2.3 - Admin+ Stored Cross-Site Scripting
- Severity: medium (CVSS 4.8 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.6% probability of exploitation in the next 30 days
- Public exploit or detection template: yes
- Published: 2022-06-20 · updated 2026-06-17
- Weakness: CWE-79
Description
The Print, PDF, Email by PrintFriendly WordPress plugin before 5.2.3 does not sanitise and escape the Custom Button Text settings, which could allow high privilege users such as admin to perform cross-Site Scripting attacks even when the unfiltered_html capability is disallowed
Affected products
- Print, PDF, Email by PrintFriendly: before 5.2.3 — fixed in 5.2.3
How to fix
Upgrade to a fixed version: Print, PDF, Email by PrintFriendly 5.2.3. Check the vendor advisory for mitigations.
References
- https://wpscan.com/vulnerability/b586b217-f91e-42d3-81f1-cc3ee3a4b01e
- https://wpscan.com/vulnerability/b586b217-f91e-42d3-81f1-cc3ee3a4b01e
Get alerted when CVE-2022-0663 or the next vulnerability affects your stack