What’s Vulnerable › Vulnerabilities
CVE-2022-0671
- Severity: critical (CVSS 9.1 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 1.3% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2022-02-18 · updated 2026-06-17
- Weakness: CWE-918
Description
A flaw was found in vscode-xml in versions prior to 0.19.0. Schema download could lead to blind SSRF or DoS via a large file.
Affected products
- vscode-xml: before 0.19.0 — fixed in 0.19.0
How to fix
Upgrade to a fixed version: vscode-xml 0.19.0. Check the vendor advisory for mitigations.
References
- https://github.com/eclipse/lemminx/blob/master/CHANGELOG.md#0190-february-14-2022
- https://github.com/redhat-developer/vscode-xml/blob/master/CHANGELOG.md#0190-february-14-2022
- https://github.com/eclipse/lemminx/blob/master/CHANGELOG.md#0190-february-14-2022
- https://github.com/redhat-developer/vscode-xml/blob/master/CHANGELOG.md#0190-february-14-2022
Get alerted when CVE-2022-0671 or the next vulnerability affects your stack