What’s Vulnerable › Vulnerabilities
CVE-2022-0678: Cross-site Scripting (XSS) - Reflected in microweber/microweber
- Severity: medium (CVSS 6.1 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 2.3% probability of exploitation in the next 30 days
- Public exploit or detection template: yes
- Published: 2022-02-19 · updated 2026-06-17
- Weakness: CWE-79
Description
Cross-site Scripting (XSS) - Reflected in Packagist microweber/microweber prior to 1.2.11.
Affected products
- microweber/microweber: before 1.2.11 — fixed in 1.2.11
How to fix
Upgrade to a fixed version: microweber/microweber 1.2.11. Check the vendor advisory for mitigations.
References
- https://github.com/microweber/microweber/commit/2b8fa5aac31e51e2aca83c7ef5d1281ba2e755f8
- https://huntr.dev/bounties/d707137a-aace-44c5-b15c-1807035716c0
- https://github.com/microweber/microweber/commit/2b8fa5aac31e51e2aca83c7ef5d1281ba2e755f8
- https://huntr.dev/bounties/d707137a-aace-44c5-b15c-1807035716c0
Get alerted when CVE-2022-0678 or the next vulnerability affects your stack