What’s Vulnerable › Vulnerabilities
CVE-2022-0684: WP Home Page Menu < 3.1 - Admin+ Stored Cross-Site Scripting
- Severity: medium (CVSS 4.8 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.7% probability of exploitation in the next 30 days
- Public exploit or detection template: yes
- Published: 2022-03-14 · updated 2026-06-17
- Weakness: CWE-79
Description
The WP Home Page Menu WordPress plugin before 3.1 does not sanitise and escape its settings, allowing high privilege users such as admin to perform Cross-Site Scripting attacks even when the unfiltered_html capability is disallowed
Affected products
- WP Home Page Menu: before 3.1 — fixed in 3.1
How to fix
Upgrade to a fixed version: WP Home Page Menu 3.1. Check the vendor advisory for mitigations.
References
- https://plugins.trac.wordpress.org/changeset/2681478
- https://wpscan.com/vulnerability/69b178f3-5951-4879-9bbe-183951d002ec
- https://plugins.trac.wordpress.org/changeset/2681478
- https://wpscan.com/vulnerability/69b178f3-5951-4879-9bbe-183951d002ec
Get alerted when CVE-2022-0684 or the next vulnerability affects your stack