What’s Vulnerable › Vulnerabilities
CVE-2022-0687: Amelia < 1.0.46 - Manager+ RCE
- Severity: high (CVSS 8.8 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 1.5% probability of exploitation in the next 30 days
- Public exploit or detection template: yes
- Published: 2022-03-21 · updated 2026-06-17
- Weakness: CWE-434
Description
The Amelia WordPress plugin before 1.0.47 stores image blobs into actual files whose extension is controlled by the user, which may lead to PHP backdoors being uploaded onto the site. This vulnerability can be exploited by logged-in users with the custom "Amelia Manager" role.
Affected products
- TMS Amelia: before 1.0.47 — fixed in 1.0.47
How to fix
Upgrade to a fixed version: TMS Amelia 1.0.47. Check the vendor advisory for mitigations.
References
- https://wpscan.com/vulnerability/3cf05815-9b74-4491-a935-d69a0834146c
- https://wpscan.com/vulnerability/3cf05815-9b74-4491-a935-d69a0834146c
Get alerted when CVE-2022-0687 or the next vulnerability affects your stack