What’s Vulnerable › Vulnerabilities
CVE-2022-0690: Cross-site Scripting (XSS) - Reflected in microweber/microweber
- Severity: medium (CVSS 6.1 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 1.1% probability of exploitation in the next 30 days
- Public exploit or detection template: yes
- Published: 2022-02-19 · updated 2026-06-17
- Weakness: CWE-79
Description
Cross-site Scripting (XSS) - Reflected in Packagist microweber/microweber prior to 1.2.11.
Affected products
- microweber/microweber: before 1.2.11 — fixed in 1.2.11
How to fix
Upgrade to a fixed version: microweber/microweber 1.2.11. Check the vendor advisory for mitigations.
References
- https://github.com/microweber/microweber/commit/f7f5d41ba1a08ceed37c00d5f70a3f48b272e9f2
- https://huntr.dev/bounties/4999a0f4-6efb-4681-b4ba-b36babc366f9
- https://github.com/microweber/microweber/commit/f7f5d41ba1a08ceed37c00d5f70a3f48b272e9f2
- https://huntr.dev/bounties/4999a0f4-6efb-4681-b4ba-b36babc366f9
Get alerted when CVE-2022-0690 or the next vulnerability affects your stack