What’s Vulnerable › Vulnerabilities
CVE-2022-0694: Advanced Booking Calendar < 1.7.0 - Unauthenticated SQL Injection
- Severity: critical (CVSS 9.8 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 1.8% probability of exploitation in the next 30 days
- Public exploit or detection template: yes
- Published: 2022-03-21 · updated 2026-06-17
- Weakness: CWE-89
Description
The Advanced Booking Calendar WordPress plugin before 1.7.0 does not validate and escape the calendar parameter before using it in a SQL statement via the abc_booking_getSingleCalendar AJAX action (available to both unauthenticated and authenticated users), leading to an unauthenticated SQL injection
Affected products
- Advanced Booking Calendar: before 1.7.0 — fixed in 1.7.0
How to fix
Upgrade to a fixed version: Advanced Booking Calendar 1.7.0. Check the vendor advisory for mitigations.
References
- https://plugins.trac.wordpress.org/changeset/2682086
- https://wpscan.com/vulnerability/990d1b0a-dbd1-42d0-9a40-c345407c6fe0
- https://plugins.trac.wordpress.org/changeset/2682086
- https://wpscan.com/vulnerability/990d1b0a-dbd1-42d0-9a40-c345407c6fe0
Get alerted when CVE-2022-0694 or the next vulnerability affects your stack