What’s Vulnerable › Vulnerabilities
CVE-2022-0720: Amelia < 1.0.47 - Customer+ Arbitrary Appointments Update and Sensitive Data Disclosure
- Severity: medium (CVSS 5.4 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.6% probability of exploitation in the next 30 days
- Public exploit or detection template: yes
- Published: 2022-03-28 · updated 2026-06-17
- Weakness: CWE-863
Description
The Amelia WordPress plugin before 1.0.47 does not have proper authorisation when managing appointments, allowing any customer to update other's booking, as well as retrieve sensitive information about the bookings, such as the full name and phone number of the person who booked it.
Affected products
- TMS Amelia: before 1.0.47 — fixed in 1.0.47
How to fix
Upgrade to a fixed version: TMS Amelia 1.0.47. Check the vendor advisory for mitigations.
References
- https://wpscan.com/vulnerability/435ef99c-9210-46c7-80a4-09cd4d3d00cf
- https://wpscan.com/vulnerability/435ef99c-9210-46c7-80a4-09cd4d3d00cf
Get alerted when CVE-2022-0720 or the next vulnerability affects your stack