What’s Vulnerable › Vulnerabilities
CVE-2022-0729: Use of Out-of-range Pointer Offset in vim/vim
- Severity: high (CVSS 8.8 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 1.6% probability of exploitation in the next 30 days
- Public exploit or detection template: yes
- Published: 2022-02-23 · updated 2026-06-17
- Weakness: CWE-823
Description
Use of Out-of-range Pointer Offset in GitHub repository vim/vim prior to 8.2.4440.
Affected products
- Apple macOS: before 13.0 — fixed in 13.0
- Debian Linux: 9.0, 10.0
- Fedoraproject Fedora: 34, 35
- vim/vim: before 8.2.4440 — fixed in 8.2.4440
How to fix
Upgrade to a fixed version: Apple macOS 13.0; vim/vim 8.2.4440. Check the vendor advisory for mitigations.
References
- http://seclists.org/fulldisclosure/2022/Oct/28
- http://seclists.org/fulldisclosure/2022/Oct/41
- https://github.com/vim/vim/commit/6456fae9ba8e72c74b2c0c499eaf09974604ff30
- https://huntr.dev/bounties/f3f3d992-7bd6-4ee5-a502-ae0e5f8016ea
- https://lists.debian.org/debian-lts-announce/2022/03/msg00018.html
- https://lists.debian.org/debian-lts-announce/2022/11/msg00009.html
- https://lists.fedoraproject.org/archives/list/package-announce%40lists.fedoraproject.org/message/7ZLEHVP4LNAGER4ZDGUDS5V5YVQD6INF/
- https://lists.fedoraproject.org/archives/list/package-announce%40lists.fedoraproject.org/message/HBUYQBZ6GWAWJRWP7AODJ4KHW5BCKDVP/
- https://security.gentoo.org/glsa/202208-32
- https://support.apple.com/kb/HT213488
- http://seclists.org/fulldisclosure/2022/Oct/28
- http://seclists.org/fulldisclosure/2022/Oct/41
Get alerted when CVE-2022-0729 or the next vulnerability affects your stack