What’s Vulnerable › Vulnerabilities
CVE-2022-0737: Text Hover < 4.2 - Admin+ Stored Cross-Site Scripting
- Severity: medium (CVSS 4.8 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.8% probability of exploitation in the next 30 days
- Public exploit or detection template: yes
- Published: 2022-04-18 · updated 2026-06-17
- Weakness: CWE-79
Description
The Text Hover WordPress plugin before 4.2 does not sanitize and escape the text to hover, which could allow high privilege users to perform Cross-Site Scripting attacks even when the unfiltered_html capability is disallowed.
Affected products
- Text Hover: before 4.2 — fixed in 4.2
How to fix
Upgrade to a fixed version: Text Hover 4.2. Check the vendor advisory for mitigations.
References
- https://wpscan.com/vulnerability/a5c9fa61-e6f1-4460-84fe-977a203bd4bc
- https://wpscan.com/vulnerability/a5c9fa61-e6f1-4460-84fe-977a203bd4bc
Get alerted when CVE-2022-0737 or the next vulnerability affects your stack