What’s Vulnerable › Vulnerabilities
CVE-2022-0741
- Severity: high (CVSS 7.5 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 1.5% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2022-04-01 · updated 2026-06-17
- Weakness: CWE-116
Description
Improper input validation in all versions of GitLab CE/EE using sendmail to send emails allowed an attacker to steal environment variables via specially crafted email addresses.
Affected products
- GitLab: from 10.0.0 before 14.6.5; from 14.7.0 before 14.7.4; from 14.8.0 before 14.8.2 — fixed in 14.6.5, 14.7.4, 14.8.2
How to fix
Upgrade to a fixed version: GitLab 14.6.5, 14.7.4, 14.8.2. Check the vendor advisory for mitigations.
References
- https://gitlab.com/gitlab-org/cves/-/blob/master/2022/CVE-2022-0741.json
- https://gitlab.com/gitlab-org/gitlab/-/issues/337601
- https://hackerone.com/reports/1286317
- https://gitlab.com/gitlab-org/cves/-/blob/master/2022/CVE-2022-0741.json
- https://gitlab.com/gitlab-org/gitlab/-/issues/337601
- https://hackerone.com/reports/1286317
Get alerted when CVE-2022-0741 or the next vulnerability affects your stack