What’s Vulnerable › Vulnerabilities
CVE-2022-0747: Infographic Maker - iList < 4.3.8 - Unauthenticated SQL Injection
- Severity: critical (CVSS 9.8 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 14.9% probability of exploitation in the next 30 days
- Public exploit or detection template: yes
- Published: 2022-03-21 · updated 2026-06-17
- Weakness: CWE-89
Description
The Infographic Maker WordPress plugin before 4.3.8 does not validate and escape the post_id parameter before using it in a SQL statement via the qcld_upvote_action AJAX action (available to unauthenticated and authenticated users), leading to an unauthenticated SQL Injection
Affected products
- Infographic Maker – iList: before 4.3.8 — fixed in 4.3.8
How to fix
Upgrade to a fixed version: Infographic Maker – iList 4.3.8. Check the vendor advisory for mitigations.
References
- https://plugins.trac.wordpress.org/changeset/2684336
- https://wpscan.com/vulnerability/a8575322-c2cf-486a-9c37-71a22167aac3
- https://plugins.trac.wordpress.org/changeset/2684336
- https://wpscan.com/vulnerability/a8575322-c2cf-486a-9c37-71a22167aac3
Get alerted when CVE-2022-0747 or the next vulnerability affects your stack