What’s Vulnerable › Vulnerabilities
CVE-2022-0750: Photoswipe Masonry Gallery <= 1.2.14 Stored Cross-Site Scripting
- Severity: medium (CVSS 5.4 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 4.4% probability of exploitation in the next 30 days
- Public exploit or detection template: yes
- Published: 2022-03-23 · updated 2026-06-17
- Weakness: CWE-79
Description
The Photoswipe Masonry Gallery WordPress plugin is vulnerable to Cross-Site Scripting due to insufficient escaping and sanitization of the thumbnail_width, thumbnail_height, max_image_width, and max_image_height parameters found in the ~/photoswipe-masonry.php file which allows authenticated attackers to inject arbitrary web scripts into galleries created by the plugin and on the PhotoSwipe Options page. This affects versions up to and including 1.2.14.
Affected products
- deanoakley Photoswipe Masonry Gallery: before 1.2.15 — fixed in 1.2.15
How to fix
Upgrade to a fixed version: deanoakley Photoswipe Masonry Gallery 1.2.15. Check the vendor advisory for mitigations.
References
- https://wordpress.org/plugins/photoswipe-masonry/
- https://www.wordfence.com/blog/2022/02/stored-cross-site-scripting-vulnerability-patched-in-a-wordpress-photo-gallery-plugin/
- https://www.wordfence.com/threat-intel/vulnerabilities/id/64624d4c-3ffb-4516-a938-0accde24c79f?source=cve
- https://wordpress.org/plugins/photoswipe-masonry/
- https://www.wordfence.com/blog/2022/02/stored-cross-site-scripting-vulnerability-patched-in-a-wordpress-photo-gallery-plugin/
- https://www.wordfence.com/threat-intel/vulnerabilities/id/64624d4c-3ffb-4516-a938-0accde24c79f?source=cve
Get alerted when CVE-2022-0750 or the next vulnerability affects your stack