What’s Vulnerable › Vulnerabilities
CVE-2022-0758: Rapid7 Nexpose Reflected XSS
- Severity: medium (CVSS 6.1 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.4% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2022-03-17 · updated 2026-06-17
- Weakness: CWE-79
Description
Rapid7 Nexpose versions 6.6.129 and earlier suffer from a reflected cross site scripting vulnerability, within the shared scan configuration component of the tool. With this vulnerability an attacker could pass literal values as the test credentials, providing the opportunity for a potential XSS attack. This issue is fixed in Rapid7 Nexpose version 6.6.130.
Affected products
- Rapid7 Nexpose: before 6.6.130 — fixed in 6.6.130
How to fix
Upgrade to a fixed version: Rapid7 Nexpose 6.6.130. Check the vendor advisory for mitigations.
References
- https://docs.rapid7.com/release-notes/nexpose/20220309/
- https://docs.rapid7.com/release-notes/nexpose/20220309/
Get alerted when CVE-2022-0758 or the next vulnerability affects your stack