What’s Vulnerable › Vulnerabilities
CVE-2022-0759
- Severity: high (CVSS 8.1 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.9% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2022-03-25 · updated 2026-06-17
- Weakness: CWE-295
Description
A flaw was found in all versions of kubeclient up to (but not including) v4.9.3, the Ruby client for Kubernetes REST API, in the way it parsed kubeconfig files. When the kubeconfig file does not configure custom CA to verify certs, kubeclient ends up accepting any certificate (it wrongly returns VERIFY_NONE). Ruby applications that leverage kubeclient to parse kubeconfig files are susceptible to Man-in-the-middle attacks (MITM).
Affected products
- kubeclient: before 4.9.3 — fixed in 4.9.3
How to fix
Upgrade to a fixed version: kubeclient 4.9.3. Check the vendor advisory for mitigations.
References
- https://github.com/ManageIQ/kubeclient/issues/554
- https://github.com/ManageIQ/kubeclient/issues/555
- https://github.com/ManageIQ/kubeclient/issues/554
- https://github.com/ManageIQ/kubeclient/issues/555
Get alerted when CVE-2022-0759 or the next vulnerability affects your stack