What’s Vulnerable › Vulnerabilities
CVE-2022-0770: Translate WordPress with GTranslate < 2.9.9 - CSRF to Account Takeover
- Severity: high (CVSS 8.8 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.6% probability of exploitation in the next 30 days
- Public exploit or detection template: yes
- Published: 2022-03-28 · updated 2026-06-17
- Weakness: CWE-352
Description
The Translate WordPress with GTranslate WordPress plugin before 2.9.9 does not have CSRF check in some files, and write debug data such as user's cookies in a publicly accessible file if a specific parameter is used when requesting them. Combining those two issues, an attacker could gain access to a logged in admin cookies by making them open a malicious link or page
Affected products
- Translate WordPress with GTranslate: before 2.9.9 — fixed in 2.9.9
How to fix
Upgrade to a fixed version: Translate WordPress with GTranslate 2.9.9. Check the vendor advisory for mitigations.
References
- https://wpscan.com/vulnerability/49abe79c-ab1c-4dbf-824c-8daaac7e079d
- https://wpscan.com/vulnerability/49abe79c-ab1c-4dbf-824c-8daaac7e079d
Get alerted when CVE-2022-0770 or the next vulnerability affects your stack