What’s Vulnerable › Vulnerabilities
CVE-2022-0771: SiteSuperCharger < 5.2.0 - Unauthenticated SQLi
- Severity: critical (CVSS 9.8 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 1.6% probability of exploitation in the next 30 days
- Public exploit or detection template: yes
- Published: 2022-05-02 · updated 2026-06-17
- Weakness: CWE-89
Description
The SiteSuperCharger WordPress plugin before 5.2.0 does not validate, sanitise and escape various user inputs before using them in SQL statements via AJAX actions (available to both unauthenticated and authenticated users), leading to Unauthenticated SQL Injections
Affected products
- SiteSuperCharger: before 5.2.0 — fixed in 5.2.0
How to fix
Upgrade to a fixed version: SiteSuperCharger 5.2.0. Check the vendor advisory for mitigations.
References
- https://wpscan.com/vulnerability/6139e732-88f2-42cb-9dc3-42ad49731e75
- https://wpscan.com/vulnerability/6139e732-88f2-42cb-9dc3-42ad49731e75
Get alerted when CVE-2022-0771 or the next vulnerability affects your stack