What’s Vulnerable › Vulnerabilities
CVE-2022-0772: Cross-site Scripting (XSS) - Stored in librenms/librenms
- Severity: medium (CVSS 4.8 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.6% probability of exploitation in the next 30 days
- Public exploit or detection template: yes
- Published: 2022-02-27 · updated 2026-06-17
- Weakness: CWE-79
Description
Cross-site Scripting (XSS) - Stored in GitHub repository librenms/librenms prior to 22.2.2.
Affected products
- librenms: before 22.2.2 — fixed in 22.2.2
How to fix
Upgrade to a fixed version: librenms 22.2.2. Check the vendor advisory for mitigations.
References
- https://github.com/librenms/librenms/commit/703745d0ed3948623153117d761ce48514e2f281
- https://huntr.dev/bounties/faae29bd-c43a-468d-8af6-2b6aa4d40f09
- https://github.com/librenms/librenms/commit/703745d0ed3948623153117d761ce48514e2f281
- https://huntr.dev/bounties/faae29bd-c43a-468d-8af6-2b6aa4d40f09
Get alerted when CVE-2022-0772 or the next vulnerability affects your stack