What’s Vulnerable › Vulnerabilities
CVE-2022-0775: WooCommerce < 6.2.1 - Subscriber+ Arbitrary Comment Deletion
- Severity: medium (CVSS 4.3 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.7% probability of exploitation in the next 30 days
- Public exploit or detection template: yes
- Published: 2024-01-16 · updated 2026-06-17
- Weakness: CWE-863
Description
The WooCommerce WordPress plugin before 6.2.1 does not have proper authorisation check when deleting reviews, which could allow any authenticated users, such as subscriber to delete arbitrary comment
Affected products
- Automattic WooCommerce: before 6.2.1 — fixed in 6.2.1
How to fix
Upgrade to a fixed version: Automattic WooCommerce 6.2.1. Check the vendor advisory for mitigations.
References
- https://developer.woocommerce.com/2022/02/22/woocommerce-6-2-1-security-fix/
- https://plugins.trac.wordpress.org/changeset/2683324
- https://wpscan.com/vulnerability/b76dbf37-a0a2-48cf-bd85-3ebbc2f394dd/
- https://developer.woocommerce.com/2022/02/22/woocommerce-6-2-1-security-fix/
- https://plugins.trac.wordpress.org/changeset/2683324
- https://wpscan.com/vulnerability/b76dbf37-a0a2-48cf-bd85-3ebbc2f394dd/
Get alerted when CVE-2022-0775 or the next vulnerability affects your stack