What’s Vulnerable › Vulnerabilities
CVE-2022-0780: SearchIQ < 3.9 - Unauthenticated Stored XSS
- Severity: medium (CVSS 6.1 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.9% probability of exploitation in the next 30 days
- Public exploit or detection template: yes
- Published: 2022-04-18 · updated 2026-06-17
- Weakness: CWE-79
Description
The SearchIQ WordPress plugin before 3.9 contains a flag to disable the verification of CSRF nonces, granting unauthenticated attackers access to the siq_ajax AJAX action and allowing them to perform Cross-Site Scripting attacks due to the lack of sanitisation and escaping in the customCss parameter
Affected products
- SearchIQ: before 3.9 — fixed in 3.9
How to fix
Upgrade to a fixed version: SearchIQ 3.9. Check the vendor advisory for mitigations.
References
- https://wpscan.com/vulnerability/0ee7d1a8-9782-4db5-b055-e732f2763825
- https://wpscan.com/vulnerability/0ee7d1a8-9782-4db5-b055-e732f2763825
Get alerted when CVE-2022-0780 or the next vulnerability affects your stack