What’s Vulnerable › Vulnerabilities
CVE-2022-0831: Cross-site Scripting (XSS) - Stored in pimcore/pimcore
- Severity: medium (CVSS 5.4 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 1.3% probability of exploitation in the next 30 days
- Public exploit or detection template: yes
- Published: 2022-03-04 · updated 2026-06-17
- Weakness: CWE-79
Description
Cross-site Scripting (XSS) - Stored in GitHub repository pimcore/pimcore prior to 10.3.3.
Affected products
- pimcore/pimcore: before 10.3.3 — fixed in 10.3.3
How to fix
Upgrade to a fixed version: pimcore/pimcore 10.3.3. Check the vendor advisory for mitigations.
References
- https://github.com/pimcore/pimcore/commit/e786fd44aac46febdbf916ed6c328fbe645d80bf
- https://huntr.dev/bounties/4152e3a7-27a1-49eb-a6eb-a57506af104f
- https://github.com/pimcore/pimcore/commit/e786fd44aac46febdbf916ed6c328fbe645d80bf
- https://huntr.dev/bounties/4152e3a7-27a1-49eb-a6eb-a57506af104f
Get alerted when CVE-2022-0831 or the next vulnerability affects your stack