What’s Vulnerable › Vulnerabilities
CVE-2022-0837: Amelia < 1.0.48 - Customer+ SMS Service Abuse and Sensitive Data Disclosure
- Severity: medium (CVSS 5.4 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.6% probability of exploitation in the next 30 days
- Public exploit or detection template: yes
- Published: 2022-04-04 · updated 2026-06-17
- Weakness: CWE-862
Description
The Amelia WordPress plugin before 1.0.48 does not have proper authorisation when handling Amelia SMS service, allowing any customer to send paid test SMS notification as well as retrieve sensitive information about the admin, such as the email, account balance and payment history. A malicious actor can abuse this vulnerability to drain out the account balance by keep sending SMS notification.
Affected products
- TMS Amelia: before 1.0.48 — fixed in 1.0.48
How to fix
Upgrade to a fixed version: TMS Amelia 1.0.48. Check the vendor advisory for mitigations.
References
- https://wpscan.com/vulnerability/0882e5c0-f319-4994-9346-aa18438fda6a
- https://wpscan.com/vulnerability/0882e5c0-f319-4994-9346-aa18438fda6a
Get alerted when CVE-2022-0837 or the next vulnerability affects your stack