What’s Vulnerable › Vulnerabilities
CVE-2022-0840: Easy Social Icons < 3.2.1 - Admin+ Stored Cross-Site Scripting in add icon
- Severity: medium (CVSS 4.8 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.6% probability of exploitation in the next 30 days
- Public exploit or detection template: yes
- Published: 2022-04-11 · updated 2026-06-17
- Weakness: CWE-79
Description
The Easy Social Icons WordPress plugin before 3.2.1 does not properly escape the image_file field when adding a new social icon, allowing high privileged users to inject arbitrary javascript even when the unfiltered_html capability is disallowed.
Affected products
- cybernetikz Easy Social Icons: before 3.2.1 — fixed in 3.2.1
How to fix
Upgrade to a fixed version: cybernetikz Easy Social Icons 3.2.1. Check the vendor advisory for mitigations.
References
- https://wpscan.com/vulnerability/9da884a9-b4dd-4de0-9afa-722f772cf2df
- https://wpscan.com/vulnerability/9da884a9-b4dd-4de0-9afa-722f772cf2df
Get alerted when CVE-2022-0840 or the next vulnerability affects your stack