What’s Vulnerable › Vulnerabilities
CVE-2022-0846: SpeakOut! Email Petitions < 2.14.15.1 - Unauthenticated SQLi
- Severity: critical (CVSS 9.8 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 8.8% probability of exploitation in the next 30 days
- Public exploit or detection template: yes
- Published: 2022-03-28 · updated 2026-06-17
- Weakness: CWE-89
Description
The SpeakOut! Email Petitions WordPress plugin before 2.14.15.1 does not sanitise and escape the id parameter before using it in a SQL statement via the dk_speakout_sendmail AJAX action, leading to an SQL Injection exploitable by unauthenticated users
Affected products
- SpeakOut! Email Petitions: before 2.14.15.1 — fixed in 2.14.15.1
How to fix
Upgrade to a fixed version: SpeakOut! Email Petitions 2.14.15.1. Check the vendor advisory for mitigations.
References
- https://wpscan.com/vulnerability/b030296d-688e-44a4-a48a-140375f2c5f4
- https://wpscan.com/vulnerability/b030296d-688e-44a4-a48a-140375f2c5f4
Get alerted when CVE-2022-0846 or the next vulnerability affects your stack