What’s Vulnerable › Vulnerabilities
CVE-2022-0850
- Severity: high (CVSS 7.1 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.4% probability of exploitation in the next 30 days
- Public exploit or detection template: yes
- Published: 2022-08-29 · updated 2026-06-17
- Weakness: CWE-200
Description
A vulnerability was found in linux kernel, where an information leak occurs via ext4_extent_header to userspace.
Affected products
- Linux kernel: before 4.4.276; from 4.5 before 4.9.276; from 4.10 before 4.14.240; from 4.15 before 4.19.198; from 4.20 before 5.4.132; from 5.5.0 before 5.10.50 — fixed in 4.14.240, 4.19.198, 4.4.276, 4.9.276, 5.10.50, 5.12.17
How to fix
Upgrade to a fixed version: Linux kernel 4.14.240, 4.19.198, 4.4.276, 4.9.276. Check the vendor advisory for mitigations.
References
- https://access.redhat.com/security/cve/CVE-2022-0850
- https://bugzilla.redhat.com/show_bug.cgi?id=2060606
- https://git.kernel.org/pub/scm/linux/kernel/git/torvalds/linux.git/commit/?id=ce3aba43599f0b50adbebff133df8d08a3d5fffe
- https://syzkaller.appspot.com/bug?id=78e9ad0e6952a3ca16e8234724b2fa92d041b9b8
- https://access.redhat.com/security/cve/CVE-2022-0850
- https://bugzilla.redhat.com/show_bug.cgi?id=2060606
- https://git.kernel.org/pub/scm/linux/kernel/git/torvalds/linux.git/commit/?id=ce3aba43599f0b50adbebff133df8d08a3d5fffe
- https://syzkaller.appspot.com/bug?id=78e9ad0e6952a3ca16e8234724b2fa92d041b9b8
Get alerted when CVE-2022-0850 or the next vulnerability affects your stack