What’s Vulnerable › Vulnerabilities
CVE-2022-0860: Improper Authorization in cobbler/cobbler
- Severity: critical (CVSS 9.1 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 2.3% probability of exploitation in the next 30 days
- Public exploit or detection template: yes
- Published: 2022-03-11 · updated 2026-06-17
- Weakness: CWE-285
Description
Improper Authorization in GitHub repository cobbler/cobbler prior to 3.3.2.
Affected products
- The cobbler Project cobbler: before 3.3.2 — fixed in 3.3.2
- Fedoraproject Fedora: 34, 35, 36
How to fix
Upgrade to a fixed version: The cobbler Project cobbler 3.3.2. Check the vendor advisory for mitigations.
References
- https://github.com/cobbler/cobbler/commit/9044aa990a94752fa5bd5a24051adde099280bfa
- https://huntr.dev/bounties/c458b868-63df-414e-af10-47e3745caa1d
- https://lists.fedoraproject.org/archives/list/package-announce%40lists.fedoraproject.org/message/D4KCNZYBQC2FM5SEEDRQZO4LRZ4ZECMG/
- https://lists.fedoraproject.org/archives/list/package-announce%40lists.fedoraproject.org/message/DYWYHWVVRUSPCV5SWBOSAMQJQLTSBTKY/
- https://lists.fedoraproject.org/archives/list/package-announce%40lists.fedoraproject.org/message/IYSHMF6MEIITFAG7EJ3IQKVUN7MDV2XM/
- https://github.com/cobbler/cobbler/commit/9044aa990a94752fa5bd5a24051adde099280bfa
- https://huntr.dev/bounties/c458b868-63df-414e-af10-47e3745caa1d
- https://lists.fedoraproject.org/archives/list/package-announce%40lists.fedoraproject.org/message/D4KCNZYBQC2FM5SEEDRQZO4LRZ4ZECMG/
- https://lists.fedoraproject.org/archives/list/package-announce%40lists.fedoraproject.org/message/DYWYHWVVRUSPCV5SWBOSAMQJQLTSBTKY/
- https://lists.fedoraproject.org/archives/list/package-announce%40lists.fedoraproject.org/message/IYSHMF6MEIITFAG7EJ3IQKVUN7MDV2XM/
Get alerted when CVE-2022-0860 or the next vulnerability affects your stack