What’s Vulnerable › Vulnerabilities
CVE-2022-0875: miniOrange Google Authenticator < 1.0.5 - CSRF to Stored Cross-Site Scripting
- Severity: medium (CVSS 4.3 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.4% probability of exploitation in the next 30 days
- Public exploit or detection template: yes
- Published: 2022-06-27 · updated 2026-06-17
- Weakness: CWE-352
Description
The Google Authenticator WordPress plugin before 1.0.5 does not have CSRF check when saving its settings, and does not sanitise as well as escape them, allowing attackers to make a logged in admin change them and perform Cross-Site Scripting attacks
Affected products
- Google Authenticator: before 1.0.5 — fixed in 1.0.5
How to fix
Upgrade to a fixed version: Google Authenticator 1.0.5. Check the vendor advisory for mitigations.
References
- https://wpscan.com/vulnerability/fefc1411-594d-465b-aeb9-78c141b23762
- https://wpscan.com/vulnerability/fefc1411-594d-465b-aeb9-78c141b23762
Get alerted when CVE-2022-0875 or the next vulnerability affects your stack