What’s Vulnerable › Vulnerabilities
CVE-2022-0876: Social comments by WpDevArt < 2.5.0 - Admin+ Stored Cross-Site Scripting
- Severity: medium (CVSS 4.8 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.6% probability of exploitation in the next 30 days
- Public exploit or detection template: yes
- Published: 2022-04-25 · updated 2026-06-17
- Weakness: CWE-79
Description
The Social comments by WpDevArt WordPress plugin before 2.5.0 does not sanitise and escape its settings, allowing high privilege users such as admin to perform cross-Site Scripting attacks even when unfiltered_html is disallowed
Affected products
- Social comments by WpDevArt: before 2.5.0 — fixed in 2.5.0
How to fix
Upgrade to a fixed version: Social comments by WpDevArt 2.5.0. Check the vendor advisory for mitigations.
References
- https://wpscan.com/vulnerability/73be6e92-ea37-4416-977d-52ee2afa022a
- https://wpscan.com/vulnerability/73be6e92-ea37-4416-977d-52ee2afa022a
Get alerted when CVE-2022-0876 or the next vulnerability affects your stack