What’s Vulnerable › Vulnerabilities
CVE-2022-0877: Cross-site Scripting (XSS) - Stored in bookstackapp/bookstack
- Severity: medium (CVSS 5.4 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.8% probability of exploitation in the next 30 days
- Public exploit or detection template: yes
- Published: 2022-03-08 · updated 2026-06-17
- Weakness: CWE-79
Description
Cross-site Scripting (XSS) - Stored in GitHub repository bookstackapp/bookstack prior to v22.02.3.
Affected products
- bookstackapp/bookstack: before 22.02.3 — fixed in 22.02.3
How to fix
Upgrade to a fixed version: bookstackapp/bookstack 22.02.3. Check the vendor advisory for mitigations.
References
- https://github.com/bookstackapp/bookstack/commit/856fca8289b7370cafa033ea21c408e7d4303fd6
- https://huntr.dev/bounties/b04df4e3-ae5a-4dc6-81ec-496248b15f3c
- https://github.com/bookstackapp/bookstack/commit/856fca8289b7370cafa033ea21c408e7d4303fd6
- https://huntr.dev/bounties/b04df4e3-ae5a-4dc6-81ec-496248b15f3c
Get alerted when CVE-2022-0877 or the next vulnerability affects your stack