What’s Vulnerable › Vulnerabilities
CVE-2022-0884: Profile Builder < 3.6.8 - Admin+ Stored Cross-Site Scripting
- Severity: medium (CVSS 4.8 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.7% probability of exploitation in the next 30 days
- Public exploit or detection template: yes
- Published: 2022-04-04 · updated 2026-06-17
- Weakness: CWE-79
Description
The Profile Builder WordPress plugin before 3.6.8 does not sanitise and escape Form Fields titles and description, which could allow high privilege user such as admin to perform Criss-Site Scripting attacks even when unfiltered_html is disallowed
Affected products
- cozmoslabs User Profile Builder – Beautiful User Registration Forms, User Profiles & User Role Editor: before 3.6.8 — fixed in 3.6.8
How to fix
Upgrade to a fixed version: cozmoslabs User Profile Builder – Beautiful User Registration Forms, User Profiles & User Role Editor 3.6.8. Check the vendor advisory for mitigations.
References
- https://plugins.trac.wordpress.org/changeset/2690776
- https://wpscan.com/vulnerability/af06b96c-105f-429c-b2ad-c8c823897dba
- https://plugins.trac.wordpress.org/changeset/2690776
- https://wpscan.com/vulnerability/af06b96c-105f-429c-b2ad-c8c823897dba
Get alerted when CVE-2022-0884 or the next vulnerability affects your stack