What’s Vulnerable › Vulnerabilities
CVE-2022-0887: Easy Social Icons < 3.1.4 - Admin+ SQL Injection
- Severity: high (CVSS 7.2 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 1.3% probability of exploitation in the next 30 days
- Public exploit or detection template: yes
- Published: 2022-04-04 · updated 2026-06-17
- Weakness: CWE-89
Description
The Easy Social Icons WordPress plugin before 3.1.4 does not sanitize the selected_icons attribute to the cnss_widget before using it in an SQL statement, leading to a SQL injection vulnerability.
Affected products
- cybernetikz Easy Social Icons: before 3.1.4 — fixed in 3.1.4
How to fix
Upgrade to a fixed version: cybernetikz Easy Social Icons 3.1.4. Check the vendor advisory for mitigations.
References
- https://wpscan.com/vulnerability/a6c1676d-9dcb-45f6-833a-9545bccd0ad6
- https://wpscan.com/vulnerability/a6c1676d-9dcb-45f6-833a-9545bccd0ad6
Get alerted when CVE-2022-0887 or the next vulnerability affects your stack