What’s Vulnerable › Vulnerabilities
CVE-2022-0901: Ad Inserter < 2.7.12 - Reflected Cross-Site Scripting
- Severity: medium (CVSS 6.1 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 3.6% probability of exploitation in the next 30 days
- Public exploit or detection template: yes
- Published: 2022-04-04 · updated 2026-06-17
- Weakness: CWE-79
Description
The Ad Inserter Free and Pro WordPress plugins before 2.7.12 do not sanitise and escape the REQUEST_URI before outputting it back in an admin page, leading to a Reflected Cross-Site Scripting in browsers which do not encode characters
Affected products
- Ad Inserter: before 2.7.12 — fixed in 2.7.12
How to fix
Upgrade to a fixed version: Ad Inserter 2.7.12. Check the vendor advisory for mitigations.
References
- http://packetstormsecurity.com/files/166626/WordPress-Ad-Inserter-Cross-Site-Scripting.html
- https://wpscan.com/vulnerability/85582b4f-a40a-4394-9834-0c88c5dc57ba
- http://packetstormsecurity.com/files/166626/WordPress-Ad-Inserter-Cross-Site-Scripting.html
- https://wpscan.com/vulnerability/85582b4f-a40a-4394-9834-0c88c5dc57ba
Get alerted when CVE-2022-0901 or the next vulnerability affects your stack