What’s Vulnerable › Vulnerabilities
CVE-2022-0936: Cross-site Scripting (XSS) - Stored in autolab/autolab
- Severity: medium (CVSS 5.4 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.7% probability of exploitation in the next 30 days
- Public exploit or detection template: yes
- Published: 2022-04-11 · updated 2026-06-17
- Weakness: CWE-79
Description
Cross-site Scripting (XSS) - Stored in GitHub repository autolab/autolab prior to 2.8.0.
Affected products
- Autolab: before 2.8.0 — fixed in 2.8.0
How to fix
Upgrade to a fixed version: Autolab 2.8.0. Check the vendor advisory for mitigations.
References
- https://github.com/autolab/autolab/commit/02d76ab3737689bba95ffe9a1c69ca5166d71c6b
- https://huntr.dev/bounties/90701766-bfed-409e-b3dd-6ff884373968
- https://github.com/autolab/autolab/commit/02d76ab3737689bba95ffe9a1c69ca5166d71c6b
- https://huntr.dev/bounties/90701766-bfed-409e-b3dd-6ff884373968
Get alerted when CVE-2022-0936 or the next vulnerability affects your stack