What’s Vulnerable › Vulnerabilities
CVE-2022-0958: Mark Posts < 2.0.1 - Admin+ Stored Cross-Site Scripting
- Severity: medium (CVSS 4.8 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.7% probability of exploitation in the next 30 days
- Public exploit or detection template: yes
- Published: 2022-04-04 · updated 2026-06-17
- Weakness: CWE-79
Description
The Mark Posts WordPress plugin before 2.0.1 does not escape new markers, allowing high privilege users such as admin to perform Cross-Site Scripting attacks even when the unfiltered_html capability is disallowed
Affected products
- Mark Posts: before 2.0.1 — fixed in 2.0.1
How to fix
Upgrade to a fixed version: Mark Posts 2.0.1. Check the vendor advisory for mitigations.
References
- https://plugins.trac.wordpress.org/changeset/2679436
- https://wpscan.com/vulnerability/05034521-6eb9-43b9-8f03-7e0de60e3022
- https://plugins.trac.wordpress.org/changeset/2679436
- https://wpscan.com/vulnerability/05034521-6eb9-43b9-8f03-7e0de60e3022
Get alerted when CVE-2022-0958 or the next vulnerability affects your stack