What’s Vulnerable › Vulnerabilities
CVE-2022-0959
- Severity: medium (CVSS 6.5 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 1.0% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2022-03-16 · updated 2026-06-17
- Weakness: CWE-434
Description
A malicious, but authorised and authenticated user can construct an HTTP request using their existing CSRF token and session cookie to manually upload files to any location that the operating system user account under which pgAdmin is running has permission to write.
Affected products
- pgadmin.org pgAdmin 4: before 6.7 — fixed in 6.7
How to fix
Upgrade to a fixed version: pgadmin.org pgAdmin 4 6.7. Check the vendor advisory for mitigations.
References
- https://bugzilla.redhat.com/show_bug.cgi?id=2063759
- https://bugzilla.redhat.com/show_bug.cgi?id=2063759
Get alerted when CVE-2022-0959 or the next vulnerability affects your stack