What’s Vulnerable › Vulnerabilities
CVE-2022-0969: Image optimization & Lazy Load < 3.3.2 - Admin+ Stored Cross-Site Scripting
- Severity: medium (CVSS 4.8 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.7% probability of exploitation in the next 30 days
- Public exploit or detection template: yes
- Published: 2022-04-11 · updated 2026-06-17
- Weakness: CWE-79
Description
The Image optimization & Lazy Load by Optimole WordPress plugin before 3.3.2 does not sanitise and escape its "Lazyload background images for selectors" settings, which could allow high privilege users such as admin to perform Cross-Site scripting attacks even when the unfiltered_html capability is disallowed.
Affected products
- Image optimization & Lazy Load by Optimole: before 3.3.2 — fixed in 3.3.2
How to fix
Upgrade to a fixed version: Image optimization & Lazy Load by Optimole 3.3.2. Check the vendor advisory for mitigations.
References
- https://plugins.trac.wordpress.org/changeset/2695242
- https://wpscan.com/vulnerability/59a7a441-7384-4006-89b4-15345f70fabf
- https://plugins.trac.wordpress.org/changeset/2695242
- https://wpscan.com/vulnerability/59a7a441-7384-4006-89b4-15345f70fabf
Get alerted when CVE-2022-0969 or the next vulnerability affects your stack