What’s Vulnerable › Vulnerabilities
CVE-2022-0970: Cross-site Scripting (XSS) - Stored in getgrav/grav
- Severity: medium (CVSS 5.4 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 1.8% probability of exploitation in the next 30 days
- Public exploit or detection template: yes
- Published: 2022-03-15 · updated 2026-06-17
- Weakness: CWE-79
Description
Cross-site Scripting (XSS) - Stored in GitHub repository getgrav/grav prior to 1.7.31.
Affected products
- getgrav grav: before 1.7.31 — fixed in 1.7.31
How to fix
Upgrade to a fixed version: getgrav grav 1.7.31. Check the vendor advisory for mitigations.
References
- https://github.com/getgrav/grav/commit/f19297d5f70476e7bedae9f2acef6b43615538b8
- https://huntr.dev/bounties/dd436c44-cbf4-48ac-8817-3a24872534ec
- https://github.com/getgrav/grav/commit/f19297d5f70476e7bedae9f2acef6b43615538b8
- https://huntr.dev/bounties/dd436c44-cbf4-48ac-8817-3a24872534ec
Get alerted when CVE-2022-0970 or the next vulnerability affects your stack