What’s Vulnerable › Vulnerabilities
CVE-2022-0981
- Severity: high (CVSS 8.8 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 1.2% probability of exploitation in the next 30 days
- Public exploit or detection template: yes
- Published: 2022-03-23 · updated 2026-06-17
- Weakness: CWE-863
Description
A flaw was found in Quarkus. The state and potentially associated permissions can leak from one web request to another in RestEasy Reactive. This flaw allows a low-privileged user to perform operations on the database with a different set of privileges than intended.
Affected products
- quarkusio quarkus: before 2.7.1 — fixed in 2.7.1
How to fix
Upgrade to a fixed version: quarkusio quarkus 2.7.1. Check the vendor advisory for mitigations.
References
- https://bugzilla.redhat.com/show_bug.cgi?id=2062520
- https://github.com/quarkusio/quarkus/issues/23269
- https://bugzilla.redhat.com/show_bug.cgi?id=2062520
- https://github.com/quarkusio/quarkus/issues/23269
Get alerted when CVE-2022-0981 or the next vulnerability affects your stack